VBA-M Forums

Full Version: When multiple VBA-Ms arelinked to Dolphin, I can't control them simultaneously
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello there, first of all a big thank you for providing this software, it's amazing!

I've been trying to play Four Swords Adventure with a friend on my laptop and we've gotten very close. I can now connect multiple VBA-Ms to a Dolphin game and have them register as controllers. The game will start, but then, we can't control our VBA-Ms simultaneously, even though "Pause when inactive" is unchecked and we are, ofcourse, using separate controls. When I switch from one VBA-M to the other, by selecting it with my mouse, I can then control the other VBA-M. So I can switch between them, just not use them at the same time! Switching controls from Xbox One controllers to, for example, keyboard, doesn't work either.

When I open two VBA-Ms and open a normal GBA game, I can control both of them at the same time. Hence, the problem occurs once I link them to my Dolpin emulator. I've tried using many different versions of both VBA-M and Dolphin, and I've always come across the same problem. These are the versions I've tried:

VBA-M 1206


I haven't gotten the VBA-M link to work with Dolphin 5.0.
I'm using Windows 10.

Really hoping that someone here can help! Thank you!
Try using my mod (vba-m svn1030e) https://www.dropbox.com/s/l2vn877z7duckt...M1030e.zip
The thread was archived before vba-m forum got rolled back http://web.archive.org/web/2015030910321...sourcecode

I remember it worked on Four Swords as i was testing the joybus on Four Swords and FF Chronicles, and you don't need bios file anymore for joybus with vba-m svn1030e
I also added a few more options to make joybus connection more stable on some games
Thanks, but I found the problem. It had to do with the drivers to my Xbox One Controllers, they didn't work. Thank you though!
(07-27-2017 12:41 AM)gostevie Wrote: [ -> ]Thanks, but I found the problem. It had to do with the drivers to my Xbox One Controllers, they didn't work. Thank you though!

How did you fix it? Please let other people who visit the forum know.

After a great deal of google searching a kind soul (Skid) on the dolphin forums pointed me to the solution. It's a driver issue as gostevie said. The newer Xbox One drivers don't broke background input functionality and it's been that way for quite some time it seems. I'll link his post here as this page has a higher google search rank than the actual solution so it might help people in the future.

"This might help if you are using xbox one controllers and windows 10: https://forums.dolphin-emu.org/Thread-gc...#pid427894"
Reference URL's