VBA-M Forums

Full Version: VBA-M [svn 854 MFC] info and download
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
General Info:
VBA-M is a [Super] Game Boy [Color / Advance] emulator for Windows, Linux & Mac. Here you can get information about the latest development build of the Windows version and download it while you're at it.

Changes in this release:
bgk: Initial version of the GTK GUI (forwardported from VBA's CVS)
xkiv: SDL: new option to slow down autofire (needed for it to work with some games)
bgk: Fixed MFC
ZachThibeau: Compiled release. used yasm instead of nasm. (nasm giving errors in release build but not in debug build), fixed url in about box to point to http://vba-m.com

VisualBoyAdvance-M SVN854
MD5: 6b37c1eb0a8cbafbd4a1fed2726b97dd
You should be aware that Google Code doesn't let you delete a file after 50 downloads. It's then there forever. So it's not the best idea to name a file "VisualBoyAdvance.7z", since you won't be able to replace that later with the "latest" version. Just so you know.
it didn't even give me an option after I uploaded it so what you are telling is pointless. I can't even rename. All builds after that will have this issue fixed though
Actually, there's a "Delete" button, if you click on a file and then look up at the top where the Search bar is. You can use that if you accidentally upload the wrong file or something - but only before 50 downloads. Was just trying to be helpful. =)
hmm I never saw that at all... oh well Tongue better luck next time.
WTF not compiled with OpenAL :O
Remove the Quick Open rom function, its causing issues with the others. if anyone has an issue, tough shit for them, the disorganised bastards can stfu. *Serious face*
I'll see what I can do Tongue and I'll compile the next build with oal it's that when I did that I was feeling lazy XD
Theres no laziness allowed on this squad! lol.

The problem seems to be caused by the UseLastDir functions effecting the other OpenRom controls.

Abeno Seimei

I get a Cannot SetCooperativeLevel 80070057 error...
I don't know what is the cause, but only happens when I select Audio:Direct Sound 8
Apparently it doesn´t do nothing because then it works normally (I tested just a bit only) It is just annoying
Sorry for my crappy English! >_<
Probably an issue with your sound drivers, or an older version of Dx9c
Same problem with Abeno. My driver is soundmax and use latest DX November08. Please fix.
Easy Fix.

Zach, remove DirectSound8.
I'll try my best Smile
We should've removed it once we put Xaudio in. on XP DirectSound/Xaudio is the same thing anyway.
Logic, but backwards compatibility? You are sure not thinking about that >_<
We don't support lower then Windows 2000, which supports OpenAL and XAudio(when after downloading the XAudio runtime files), so there's no loss of compatibility.
Reference URL's