VBA-M Forums

Full Version: MX Simulator won't recognise triggers
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
G'day all,

I downloaded this program for the sole purpose of attaining better throttle control in MX Simulator, a devilishly hard game on the best of days, and despite my best efforts it refuses to acknowledge the existence of the trigger axes.Angry

[Image: other_zpse111bb21.png]

[Image: setup_zps41a57d95.png]
I keep trying to load the XBCD 360 Emu in the XBCD setup utility, and it never shows up again when I open the program anew.

Then I just plain have no idea how to get that other program to work.

Requesting halp, k thanks.

The demo is available for free online, if anyone who has a working controller could check whether MX Simulator recognises their triggers, that would be great, at least then I'd know it's possible.

Here's a dancing badger for motivation.Badger
delete the x360ce ini and configure it as the sticked thread describes
(01-21-2013 03:10 PM)Squall Leonhart Wrote: [ -> ]delete the x360ce ini and configure it as the sticked thread describes

No matter what I do it won't work..

my joy. cpl file is exactly as it should be, I go into XBCD and select XBCD 360 Emu, then exit that and go to x360ce, which - EVERY time - shows the same as the image I posted previously, triggers default to IHaxis3 and IHaxis6, changing them to your specified axes changes nothing, they still don't register in MX simulator.

If it's not too much to ask, any chance you can check in the demo of MX simulator to see if they will even work?


Thanks for the quick response too, really want to get this to work as throttle control is the be-all and end-all of racing games, and being able to brake and throttle at the same time is crucial.


It works if I set the triggers as buttons... Not quite a solution however
IAxis not the same as IHAxis
check that passthrough is NOT enabled on the advanced tab.
Yep I know I need IAxis and not IHaxis, just saying it makes no difference either way, have been turning pass-through off every time also.

It never defaults to the correct (IAxis 3 /IAxis 6) setting in x360ce, and the setting from the internet on x360ce that the other 10 people are using has the triggers mapped to IHaxis 3 and 6, so no idea there.

It just refuses to register the triggers in-game. The one time I got it to work was setting them as triggers as buttons in XBCD setup, then setting IAxis 3 /6 correctly, but then I had zero modulation, and pressing both triggers simultaneously still canceled each other out.

I keep having to uninstall this program and put that motioninjoy thing on to actually play games, which is a shame because this is a great sounding idea, to split the axes and give full functionality, I just wish I could get it to work.

Wouldn't work on FIFA either, so I don't think it's just that game.

Controller is an Afterglow AX.1 PL-3602, running windows 7, done everything multiple times following the exact instructions, tried on my brothers computer with his help and no luck either.

Thanks again for the speedy reply, hope you can help me figure out what the hell I'm doing wrong.
grab r184 from the x360ce project page and give that a try.
Reference URL's