Post Reply 
Thread Rating:
  • 11 Vote(s) - 3.64 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GDB support broken on OSX
Author Message
matthewcampbell Offline
Junior Member

Posts: 2
Joined: May 2017
Reputation: 0
Post: #1
GDB support broken on OSX

Hey I built the latest code from GitHub and I tried to get GDB to connect. Doing the following

1) Break on load inside vba-m
2) gdb
3) target remote :55555

however I get a few errors and can't really do much

Error 1:
warning: No executable has been specified and target does not support
determining executable automatically. Try using the "file" command.

Error 2:
(gdb) continue
Cannot execute this command without a live selected thread.
(gdb) thread 1
Thread ID 1 has terminated.

It seems like I can't get the emulator to start with GDB connected. Any suggestions thanks!
I think it must be a bug on the Wxwidgets builds or OS X in general. I tried it on linux and was able to get it to work first time with this tutorial. However the linux builds use SDL and have more command line options like --gdb
(This post was last modified: 05-09-2017 11:19 PM by matthewcampbell.)
05-09-2017 11:19 PM
Find all posts by this user Quote this message in a reply
Post Reply 

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

 Quick Theme: