Jump to content
Visual Boy Advance-M
Crowley-Reigns

Throttle/speed Problem

Recommended Posts

So, after i got DirectX and i managed to fix the Xaudio 2, the game is still stuck around 400% speed. I tried to manage the settings to lower the framerate, but it's not working. The sound and screen are both at 400%, so i guess they're synced.. How can i get the speed back to 100%?


Also, The rom i'm trying to run is Pokemon Emerald, i've tried several other roms as well, and its still giving me the same problem, so i doubt it's a bug in the rom..

Share this post


Link to post
Share on other sites

So, after i got DirectX and i managed to fix the Xaudio 2, the game is still stuck around 400% speed. I tried to manage the settings to lower the framerate, but it's not working. The sound and screen are both at 400%, so i guess they're synced.. How can i get the speed back to 100%?


Also, The rom i'm trying to run is Pokemon Emerald, i've tried several other roms as well, and its still giving me the same problem, so i doubt it's a bug in the rom..

 

Have you tried setting Throttle to "100%"? I recently updated from VBA-M SVN1229 MFC and i seem to have to put throttle at "100%" to get 1x game speed, in 1229 it ran at 1x with the "No throttle" setting, so i guess they either reversed what it does (seems logical since checking the meaning of "throttle" seems to be "to control/limit"), or either the 1229 or the recent builds are bugged. I've yet to encounter a problem in the new-er/-est build(s) when putting throttle to "100%" though, so that should work.

 

Maybe someone more code-"adept" and/or involved with the project can elaborate?

 

PS. Topic is kinda old from what i see and apperantly the forum got (mostly) deleted by hackers and i haven't read the webarchives save, so i don't know if you've already got it solved.

Share this post


Link to post
Share on other sites

Crowley, did this problem only occur in full screen, and were you using vsync? I had a very similar issue with the SVN 1490 version when in full screen. All tested games would run the emulator at ~ 150%, and the problem turned out to be the full screen resolution I had selected. I suppose my graphics card or the emulator didn't take kindly to 1600x900.

 

The settings that did the trick and offered smooth graphical performance were:

- Vsync and Triple Buffering under Options > Video > Render API

- Changing the resolution to something different (1280x800 in my case) under Options > Video > Select fullscreen mode... if you're shooting for a res that's some even multiple of the GBA and it does not exist in the list, create it in your GPU control panel (then reboot, in my case).

- Leaving the options of "no throttle" and "no frameskip" selected under Options > Speed.

 

Reason I recommend that last point is because the frame judder was driving me crazy after setting Throttle and/or Frameskip to 100% and Automatic, respectively.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×