Jump to content
Visual Boy Advance-M

GDB support broken on OSX

Recommended Posts

Hey I built the latest code from GitHub and I tried to get GDB to connect. Doing the following


1) Break on load inside vba-m

2) gdb

3) target remote :55555


however I get a few errors and can't really do much


Error 1:

warning: No executable has been specified and target does not support

determining executable automatically. Try using the "file" command.


Error 2:

(gdb) continue

Cannot execute this command without a live selected thread.

(gdb) thread 1

Thread ID 1 has terminated.

It seems like I can't get the emulator to start with GDB connected. Any suggestions thanks!

I think it must be a bug on the Wxwidgets builds or OS X in general. I tried it on linux and was able to get it to work first time with this tutorial. However the linux builds use SDL and have more command line options like --gdb



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now