Jump to content
Visual Boy Advance-M
bgK

Need help testing GTK joystick support

Recommended Posts

The GTK+ port recently got joystick support. It was implemented using the very same code as the SDL port, thus it should be pretty good already. However I need your help to do strange things with your joystick and gvbam :banana:. Please report here any strange behavior you may notice.

 

Here is an Ubuntu package containing a recent build of the SDL and GTK+ ports :

http://bgkweb.googlepages.com/vbam_0.svn701-1_i386.deb

Share this post


Link to post
Share on other sites

I do not have a joypad, but I saw you made a deb so I cared to try anyway, since I couldn't compile the GTK GUI before. The package installs with some work, but if you don't have all dependencies it fails, so you have to install them manually. Could you fix it? Here's the output I got:

 

ruti@ruti-desktop:~$ sudo dpkg -i /home/ruti/Desktop/vbam_0.svn696-1_i386.deb

Selecting previously deselected package vbam.

(Reading database ... 143125 files and directories currently installed.)

Unpacking vbam (from .../vbam_0.svn696-1_i386.deb) ...

dpkg: dependency problems prevent configuration of vbam:

vbam depends on libglademm-2.4-1c2a (>= 2.6.0); however:

Package libglademm-2.4-1c2a is not installed.

vbam depends on libgtkglextmm-x11-1.2; however:

Package libgtkglextmm-x11-1.2 is not installed.

dpkg: error processing vbam (--install):

dependency problems - leaving unconfigured

Errors were encountered while processing:

vbam

---------------

The dependencies are available in Ubuntu's repos (and the package worked when I had them installed), it just seems like something is set up wrong in the package.

 

I also think I found a bug in the GUI, related to input. It seems the B button is constantly pressed. This doesn't happen in the SDL version.

Share this post


Link to post
Share on other sites

Nah, nothing's wrong with it. dpkg just isn't a very user friendly installation frontend. I'd recommend something like gdebi to install the deb with.

Share this post


Link to post
Share on other sites

dualscreenman is right, dpkg is not able to install package dependencies. Double clicking on the package should bring up Gedebi, which is a lot better.

 

There was indeed a bug with autofire. I fixed it in rev 701, and updated the link in the first post with a new package.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×