Jump to content
Visual Boy Advance-M
chikani

[FIXED]Setting of Pause when inactive

Recommended Posts

When the main body is ended, the setting of "Pause when inactive" is not preserved.

When "GbPrinter=0" the under "pauseWhenInactive=0" is written directly in the ini file, it seems to be preserved.

Share this post


Link to post
Share on other sites

I was going to report the same problem.

 

In the current version (1.8.0, 16/06/09), when you toggle the "Options/Emulator/Pause when inactive" value, the setting isn't saved in vba.ini. The setting still works if you manually write the line "pauseWhenInactive=0" line in vba.ini, so this is properly a GUI bug.

Share this post


Link to post
Share on other sites

Thanks guys, the auto frame skipping setting is doing the same thing it seems,

 

the setting save code just needs to be updated to fit changes to the emulator i think.

Share this post


Link to post
Share on other sites

The auto frame skip option bug is even worse. Whereas we can manually adding pauseWhenInactiv=0 in vba.ini, adding autoFrameSkip=1 does nothing; M just rewrites the value to autoFrameSkip=0. So auto frame skip feature is effectively disabled in version 878.

Share this post


Link to post
Share on other sites

Grouse jbo, It must've broken when mudlord fixed the Settings to be loaded after the window was created and the issue with the sound quality setting. bgK's changes to the MFC broke it somewhat...

 

hopefully both issues are fixed now..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×