Jump to content
Visual Boy Advance-M
zuargo

Problems with some Yu-Gi-Oh! games

Recommended Posts

Hello everybody

 

As says the thread subject I am having some problems with VBAM.

 

I use Archlinux x86

VBAM svn build 1016

Rendering Method: OpenGL

Filters: none

vsync: What is that?, where can I see whether have I enabled it? :P

triple buffering: same of above :P

Screenshot of Display menu:

a1884ll2mpvvibdbnp0z.png

I am using a Nvidia 9500 GT (1GB) videocard

$HOME/.config/gvbam/config file:

 

[Directories]
gb_roms=/home/zuargo
gba_roms=/home/zuargo
batteries=/home/zuargo/.config/gvbam
saves=/home/zuargo/.config/gvbam
captures=/home/zuargo/.config/gvbam

[Core]
load_game_auto=0
frameskip=0
use_bios_file=0
bios_file=
enable_rtc=0
save_type=0
flash_size=64
gb_border=0
gb_printer=0
gb_use_bios_file=0
gb_bios_file=
emulator_type=0
pause_when_inactive=1
show_speed=0

[Display]
scale=2
filter2x=0
filterIB=0
output=1

[sound]
mute=1
sample_rate=48000
volume=1

[input]
active_joypad=0
joypadSDL0_left=100
joypadSDL0_right=103
joypadSDL0_up=114
joypadSDL0_down=102
joypadSDL0_A=65456
joypadSDL0_B=65454
joypadSDL0_select=65451
joypadSDL0_start=65421
joypadSDL0_L=65457
joypadSDL0_R=65458
joypadSDL0_speed=65459
joypadSDL0_capture=65481
joypadSDL0_autoA=113
joypadSDL0_autoB=119
joypadSDL1_left=65361
joypadSDL1_right=65363
joypadSDL1_up=65362
joypadSDL1_down=65364
joypadSDL1_A=122
joypadSDL1_B=120
joypadSDL1_select=65288
joypadSDL1_start=65293
joypadSDL1_L=97
joypadSDL1_R=115
joypadSDL1_speed=32
joypadSDL1_capture=65481
joypadSDL1_autoA=113
joypadSDL1_autoB=119
joypadSDL2_left=65361
joypadSDL2_right=65363
joypadSDL2_up=65362
joypadSDL2_down=65364
joypadSDL2_A=122
joypadSDL2_B=120
joypadSDL2_select=65288
joypadSDL2_start=65293
joypadSDL2_L=97
joypadSDL2_R=115
joypadSDL2_speed=32
joypadSDL2_capture=65481
joypadSDL2_autoA=113
joypadSDL2_autoB=119
joypadSDL3_left=65361
joypadSDL3_right=65363
joypadSDL3_up=65362
joypadSDL3_down=65364
joypadSDL3_A=122
joypadSDL3_B=120
joypadSDL3_select=65288
joypadSDL3_start=65293
joypadSDL3_L=97
joypadSDL3_R=115
joypadSDL3_speed=32
joypadSDL3_capture=65481
joypadSDL3_autoA=113
joypadSDL3_autoB=119

 

Problem with Yu-Gi-Oh! World Championship Tournament 2004 (E):

 

I have noticed some words in the list of cards are not shown correctly:

 

instantánea249.png

 

instantánea246.png

 

instantánea245.png

 

Problem with Yu-Gi-Oh! Worldwide Edition (E):

 

The game, randomly, freezes when the effect of the card Blind Destruction is activated. This effect displays a special screen in the game, where be can see rolling a six-sided die. So when the game should go back at the battle screen, it freezes. This problem also occurs with another card effect but I don't remember its name, however the effect is similar (six-sided die rolling in a non-battle screen).

 

I have attached a save state (0954 - Yu-Gi-Oh! Worldwide Edition (E)(Eurasia)5.sgm) where be can see when the card is activated by the opponent after to select "completar tu turno" (it is something like "Finish your turn", second option in the green menu), and discard one card from the hand. The opponent will activate the effect of Blind Destruction card and the screen, with the rolling die, will be shown. At this time the issue happens. But as I said, previously, the problem not always occurs. Try again and over, and over (If necessary) and it will happen. I can say that of 10 tries 6 resulting in the named error.

 

Also, I have attached another save state (0954 - Yu-Gi-Oh! Worldwide Edition (E)(Eurasia)3.sgm) where be can see the game can't go back to the previous screen (battle screen), simply it freezes.

 

Thanks so much for reading this thread :P

Share this post


Link to post
Share on other sites

vsync: What is that?, where can I see whether have I enabled it? Tongue

triple buffering: same of above

 

Google it?

 

The graphics issue may be something that occured on the gba itself, otherwise its a timing issue that we need to sort out.

 

The freeze doesn't appear to occur on win32 so it might be something to do with the GTK specific build.

Share this post


Link to post
Share on other sites

The first game, is a bug in the game itself. the text buffer is not long enough causing the line to extend into the next card slot, when you slide up the new text takes priority over the current text and is rendered on top causing it to appear like that.

 

The second game..... it might be fixed now, will need you to test it in the latest svn.

Share this post


Link to post
Share on other sites

The first game, is a bug in the game itself. the text buffer is not long enough causing the line to extend into the next card slot, when you slide up the new text takes priority over the current text and is rendered on top causing it to appear like that.

 

The second game..... it might be fixed now, will need you to test it in the latest svn.

 

Give me some days I will try it out again

 

Thanks

Share this post


Link to post
Share on other sites

I'll hope to have a build uploaded for SVN 1185 or newer by the end of the long weekend.

 

Ah, you did say GTK, so i suppose you'll build it yourself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×