Jump to content
Visual Boy Advance-M

Recommended Posts

anyways here are some untested binaries for win32 AND win64

this is completely experimental, so test it if you want to at your own risk, we are not liable if this breaks your computer or kills your kitten

 

for the 64bit binary you can get it from here at Sourceforge

 

and for the 32bit binary which is the recommended build is located here

Share this post


Link to post
Share on other sites

You weren't kidding when you said they were "experimental"—they don't work. The 64-bit build crashes (and doesn't even have the decency to throw an error message) when you try to open a rom, and the 32-bit build won't even run in the first place.

 

I'm using Windows 7 Home Premium 64-bit.

Share this post


Link to post
Share on other sites

I've tested both via a clean windows 7 Professional SP1 64bit and 32bit vm and both worked for me and also worked via wine, so they work at least for myself you maybe maybe missing a runtime, I compiled the main executable against the vs2010 runtime so make sure you have that installed

Share this post


Link to post
Share on other sites

No luck—I installed the latest VS 2010 runtimes (both x86 and x64), and got the same results—x64 version crashes with no error message when launching a rom, and the x86 version doesn't even run at all.

Share this post


Link to post
Share on other sites

No luck—I installed the latest VS 2010 runtimes (both x86 and x64), and got the same results—x64 version crashes with no error message when launching a rom, and the x86 version doesn't even run at all.

 

I'm having this same exact issue. The 64 bit version closes at opening a rom, and 32 bit never opens. I, too, have both the newest VS runtimes installed.

Share this post


Link to post
Share on other sites

ok confirmed for the 32bit but the 64bit it's a dsound issue, so when it opens just go to options->sound in the advance tab and select openal or sdl and it should work, I'll look at it again in a little bit and see about fixing the other issues as well

Share this post


Link to post
Share on other sites

Okay, 64-bit build is working, but I can't alter Game Boy settings—opening the dialog causes an error, and changes made to the settings can't be saved.

Share this post


Link to post
Share on other sites

The 64 bit version also works for me too now. However, if you try to change the fullscreen image filter, the emulator completely halts and has to be closed through task manager.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×